Mit Strukturdokumenten arbeiten
Im Hauptfenster von AtomLens kannst du ein Molekül oder einen Reaktionskontext einfügen, darstellen, untersuchen und exportieren.
Das Dokumentfenster besteht aus einer erweiterten interaktiven Zeichenfläche und der Seitenleiste „Übersicht“ auf der rechten Seite. Die Symbolleiste bietet immer separate Funktionen, um die gesamte Struktur oder Reaktionsquelle in einem großen Dialogfeld zu bearbeiten und die aktuelle Struktur oder Reaktion in Ketcher zu zeichnen.
Dokumente öffnen
Öffne Chemistry-Dateien im Finder. File > Open..., aus Open Recent, aus Lokale Molekül-Dateien, oder aus dem Verwaltetes Repository Browser. AtomLens öffnet gängige Molekülformate, Reaktionsformate, chemische Eingaben im Klartext sowie moderne Notationen wie CXSMILES, wenn diese in eine unterstützte Texteingabe eingebettet sind.
- Verwende ein Dokumentfenster, wenn du bereits weißt, welche Datei oder welchen Text du dir ansehen möchtest.
- Nutze „Lokale Dateien durchsuchen…“ bei macOS, wenn du zuerst beliebige lokale Dateien finden möchtest. Bei iPad kehrt „Bibliothek“ zu denselben Such- und Filteroptionen zurück; „Dokumente öffnen“ lädt deine Tabs wieder.
- Reaktionsdokumente kannst du als vollständige Reaktionen anzeigen, als Reaktionsdateien exportieren oder Teilnehmer für Teilnehmer speichern, wenn du einzelne Strukturen brauchst.
Eingabe und Rendering
Wähle in der Symbolleiste „Strukturquelle bearbeiten“ oder „Reaktionsquelle bearbeiten“ aus. Der große Editor akzeptiert unterstützte chemische Bezeichnungen und speichert die Änderungen vorübergehend, bis du auf „Übernehmen & Darstellen“ klickst. Mit „Abbrechen“ bleibt das Dokument unverändert.
- Gib einen IUPAC-Namen ein … wandelt einen unterstützten Namen im Editor in eine Strukturquelle um. Wende das Ergebnis an, um das Dokument zu aktualisieren.
- Verwende den Quelltext-Editor, um SMILES, InChI, MOL/SDF oder den Reaktionstext zu überprüfen oder zu ersetzen.
- Mit „Struktur zeichnen“ oder „Reaktion zeichnen“ öffnest du einen separaten Zeichnungseditor. Übernimm die dort vorgenommenen Änderungen, um das aktuelle Dokument zu aktualisieren.
- Für eine neue Zeichnung, Datei > Neu Öffnet den Editor für chemische Formeln. Siehe der Zeichen-Workflow.
Mit dem aktuellen Molekül (macOS) suchen
Nutze die Suchfunktion in der Symbolleiste eines Molekülfensters, um das verwaltete Repository anhand der angezeigten Struktur zu durchsuchen.
- „Ähnliche Strukturen finden…“ fragt nach einem Mindestwert für den Tanimoto-Ähnlichkeitswert zwischen 0 und 1 und öffnet anschließend die Ergebnisse in einer Rangliste.
- „Find Substructure Matches“ sucht nach Molekülen im Repository, die die angezeigte Struktur enthalten.
- Bei einer Datei mit mehreren Molekülen bezieht sich die Abfrage nur auf das aktuell angezeigte Molekül. Ihre Änderungen werden berücksichtigt; Sie müssen die Abfrage nicht speichern oder ins Repository importieren.
- Die Ergebnisse werden in einem separaten Fenster geöffnet. Das Quelldokument und etwaige bestehende Suchanfragen im Browser bleiben weiterhin verfügbar. Bei einem leeren Dokument oder einer Reaktion ist die Suche deaktiviert.
Canvas- und Stil-Tools
Die zentrale Arbeitsfläche ist interaktiv. Du kannst zoomen, drehen, zurücksetzen und einen Screenshot machen, ohne das Dokumentfenster zu verlassen.
- Die Schieberegler für Zoom und Drehung ändern die aktuelle Darstellung sofort.
- „Snapshot“ speichert die aktuelle Ansicht als Bild des Zeichenbereichs.
- Nutze die Stecknadel neben „Zurücksetzen“, um das Molekül- oder Reaktions-HUD sichtbar zu halten. Die ausgefüllte Stecknadel bedeutet „angeheftet“; die durchgestrichene Stecknadel bedeutet „nicht angeheftet“. Jede neue Arbeitsfläche ist zunächst nicht angeheftet, und wenn du die Anheftung aufhebst, wird das übliche Ausblenden nach Inaktivität wiederhergestellt.
- Die Symbolleiste enthält Steuerelemente für den Darstellungsstil, wie zum Beispiel Elementfarben, Bindungsfarben, Aromatenkreise, Hervorhebungsstil und zugehörige Zeichenoptionen.
- Reaktionsdokumente verwenden dasselbe Interaktionsmodell für den Zeichnungsbereich, mit zusätzlichen reaktionsbezogenen Steuerelementen, wenn Informationen zur Atomkarte verfügbar sind.
2D- und 3D-Ansichten von Molekülen
Die Molekül-Leinwand bietet eine 2D/3D-Auswahl. Ganze Reaktionen bleiben in 2D. Eine 3D-Ansicht ist eine Visualisierung und kein Beweis für eine experimentell gemessene oder energieminimierte Konformation.
- Bei „Ball“ geht es um Bälle und Stäbe, bei „Stick“ stehen Bindungen im Vordergrund und bei „CPK“ kommen raumfüllende Kugeln zum Einsatz.
- Verwende das Paletten-Steuerelement für die Farben der Atome. Die CPK-Darstellung und die CPK-Farbpalette sind separate Auswahlmöglichkeiten. Siehe Verfügbare Farbpaletten und Quellenangaben.
- Zieh mit der Maus oder klick und zieh auf dem Trackpad, um das 3D-Modell zu drehen. Scrolle mit zwei Fingern, um es über die Arbeitsfläche zu verschieben, zoome durch Auf- und Zuziehen und drehe zwei Finger, um zu rollen. Auch mit dem Mausrad kannst du zoomen. Das Scrollen auf dem Trackpad richtet sich nach deinen macOS-Scroll-Einstellungen; in 2D wird die Zeichnung durch Ziehen verschoben.
- Mit „Snapshot“ wird die aktuelle 3D-Ansicht als PNG gespeichert. Unter „Datei > Teilen“ und beim SVG-Export wird die 2D-Darstellung verwendet, einschließlich der Freigabeformate PNG und PDF.
- In iPad kannst du mit einem Finger das 3D-Modell drehen und mit zwei Fingern über die Arbeitsfläche verschieben. Mit zwei Fingern zoomen und durch Drehen der Finger rollen. Die automatische Drehung wird während der Gesten unterbrochen und setzt sich fort, sobald diese beendet sind – auf beiden Plattformen. Schalte sie aus, um die Ausrichtung beizubehalten. Die Schieberegler für X, Y und Z, „Zurücksetzen“ und „Schnappschuss“ bleiben im HUD erhalten.
Übersichts-Seitenleiste
Die Seitenleiste „Übersicht“ fasst zusammen, was AtomLens über die aktuelle Struktur oder den ausgewählten Reaktionspartner weiß. Zu den typischen Werten gehören die Formel, das Molekulargewicht, die monoisotopische Masse, die Ringanzahl, der „Rule-of-Five“-Status sowie generierte Kennungen wie SMILES oder InChI.
- Mit den Kopier-Schaltflächen neben den Bezeichnern kannst du genaue Werte schnell in andere Tools übertragen.
- Wenn du mit einer Reaktion arbeitest, folgt die Übersicht dem ausgewählten Teilnehmer, anstatt auf die gesamte Reaktion fixiert zu bleiben.
- Blende die Übersichts-Seitenleiste aus, wenn du mehr Arbeitsfläche brauchst. Ein separater Teilnehmerbereich steht weiterhin für Reaktionen zur Verfügung. Als „Nicht verfügbar“ gekennzeichnete Werte konnten nicht berechnet werden; sie sind nicht gleich Null.
Exportieren und teilen
Verwendung File > Export... wenn du das aktuelle Molekül oder die aktuelle Reaktion in ein anderes chemisches Format umschreiben möchtest. Verwende File > Share Wenn du das aktuelle Molekül oder die gesamte Reaktionsdarstellung als SVG, PNG oder PDF über die üblichen macOS-Freigabeziele versenden möchtest.
- Zu den gängigen Exportoptionen für Moleküle gehören
.svgDarstellungen sowie chemische Formate wie zum Beispiel.sdf,.smi,.inchi,.mol2,.cml, und.rgfwenn R-Gruppen-Daten geschrieben werden können. - ChemDraw CDX und ChemDraw CDXML exportieren bearbeitbare 2D-Moleküle und Reaktionen. Nicht unterstützte chemische Strukturen führen zu einer Fehlermeldung. Beide Formate können auch im Managed Repository geöffnet oder importiert werden. Nicht unterstützte chemische Strukturen führen zu einer Fehlermeldung; die ursprüngliche Zeichnung bleibt beim Import in das Repository erhalten.
- Reaktionsdokumente können exportiert werden als
.rxn,.rdf,.rsmi,.rinchi, oder reaktionsfähig.cml. Save to Managed Repository...Erstellt einen verwalteten Repository-Eintrag anstelle eines allgemeinen Exports.- Der Speicherablauf im Repository ist bewusst eingeschränkter als beim Export: Er akzeptiert nur chemische Dateiformate, die AtomLens direkt in einem Molekül- oder Reaktionsfenster wieder öffnen kann.
© 2026 Dr. Sascha Losko – Obscure Essentials. Alle Rechte vorbehalten.