处理结构化文档
AtomLens 的主文档窗口是您粘贴、渲染、检查和导出分子或反应上下文的地方。
文档窗口由一个展开的交互式绘图画布和右侧的“概览”侧边栏组成。工具栏始终提供两项独立操作:一项是在大型对话框中编辑整个结构或反应源,另一项是在Ketcher中绘制当前结构或反应。
打开文档
您可以从“Finder”中打开 chemistry 文件,从 File > Open...,来源: Open Recent,来源: 本地分子文件,或从 托管仓库 浏览器。AtomLens 支持打开常见的分子格式、反应格式、纯文本化学输入,以及当其嵌入到受支持的文本输入中时,还支持 CXSMILES 等现代符号表示法。
- 当您已经知道要查看的是哪个文件或文本时,请使用文档窗口。
- 若需先查找任意本地文件,请在 macOS 上使用“浏览本地文件...”功能。在 iPad 上,“库”将返回相同的搜索和筛选功能;“打开文档”则会恢复您的标签页。
- 反应文档既可以作为完整的反应进行查看,也可以导出为反应文件,或者在需要单个结构时按参与者逐一保存。
输入和渲染
在工具栏中选择“编辑结构源”或“编辑反应源”。大型编辑器支持输入符合规范的化学文本,并在点击“应用并渲染”之前会暂存所做的更改。点击“取消”则文档保持不变。
- 输入一个IUPAC名称……将支持的名称转换为编辑器中的结构源。应用结果以更新文档。
- 使用源代码编辑器查看或替换 SMILES、InChI、MOL/SDF 或反应文本。
- “绘制结构”或“绘制反应”会打开一个单独的绘图编辑器。应用其中的更改即可更新当前文档。
- 对于一个新的图纸, “文件” > “新建” 打开化学结构式编辑器。参见 绘图工作流程.
使用当前分子(macOS)进行搜索
使用分子窗口工具栏中的“搜索”功能,根据显示的结构在“受管存储库”中进行搜索。
- “查找相似结构…”会要求输入0到1之间的最小Tanimoto相似度得分,然后显示按排名排序的结果。
- “查找子结构匹配”可查找存储库中包含所显示结构的分子。
- 对于包含多个分子的文件,查询仅针对当前显示的分子。已进行的编辑将被包含在内;无需将查询保存或导入到存储库中。
- 搜索结果将在新窗口中打开。源文档和浏览器中现有的搜索结果仍可查看。对于空文档或反应,搜索功能将被禁用。
画布和样式工具
中央画布支持交互操作。您无需离开文档窗口,即可进行缩放、旋转、重置和截图操作。
- 缩放和旋转滑块会立即更改当前显示的内容。
- “快照”功能将当前视图作为绘图区域的图像保存下来。
- 使用“重置”旁边的图钉图标,可让分子或反应HUD保持可见。实心图钉表示“已固定”;带叉的图钉表示“已取消固定”。每个新画布初始状态均为“已取消固定”,取消固定后,在闲置时将恢复常规的淡出效果。
- 该工具栏提供了绘图样式控制项,例如元素颜色、键色、芳香环、高亮样式以及相关的绘图选项。
- 反应文档在绘图部分采用相同的交互模型,当有原子映射信息时,还会增加支持反应的控件。
2D和3D分子视图
分子画布提供了一个 2D/3D 选择器。整个反应过程仍以 2D 形式呈现。3D 视图仅是一种可视化展示,并非对实验测得或能量最小化构象的证明。
- Ball 展示了球和棍,Stick 强调了键,而 CPK 则使用了填充空间的球体。
- 使用调色板控件设置原子颜色。CPK 表示法和 CPK 调色板是两个独立的选项。参见 可用的调色板和来源说明.
- 使用鼠标拖动或在触控板上点击并拖动,可旋转 3D 模型。用两根手指滚动可在画布上移动模型,双指捏合可缩放,双指旋转可滚动。鼠标滚轮也可用于缩放。触控板的滚动行为遵循您的 macOS 滚动偏好设置;在 2D 模式下,拖动可移动绘图。
- “快照”功能将当前的 3D 视图保存为 PNG 格式。而“文件”>“共享”和 SVG 导出功能则使用 2D 渲染图,包括 PNG/PDF 共享格式。
- 在 iPad 上,用一根手指拖动可旋转 3D 模型,用两根手指拖动可在画布上移动模型。双指捏合可缩放,双指旋转可滚动。在两个平台上,执行手势操作期间自动旋转功能会暂停,手势结束时自动旋转功能将恢复。若需保持固定方向,请关闭该功能。X、Y 和 Z 滑块、“重置”和“快照”仍会显示在 HUD 中。
概述侧边栏
“概述”侧边栏总结了 AtomLens 所掌握的关于当前结构或所选反应参与者的信息。典型值包括化学式、分子量、单同位素质量、环数、“五规则”状态,以及生成的标识符(如 SMILES 或 InChI)。
- 标识符旁边的“复制”按钮可让您快速将精确数值复制到其他工具中。
- 当您查看一条互动时,概览会跟随所选参与者,而不是始终固定显示整个互动内容。
- 若需更大的画布,请隐藏“概览”侧边栏。参与者区域仍可单独用于显示互动反应。标记为“不可用”的数值无法计算,但它们不为零。
导出和分享
使用 File > Export... 当您想将当前的分子或反应转换为另一种化学格式时,请使用 File > Share 当您希望通过标准的macOS分享渠道,将当前分子或整个反应示意图以SVG、PNG或PDF格式发送时。
- 常见的分子导出选项包括
.svg画面表现以及化学相关格式,例如.sdf,.smi,.inchi,.mol2,.cml,以及.rgf何时可以写入R组数据。 - ChemDraw CDX 和 ChemDraw CDXML 可导出可编辑的 2D 分子和反应。若包含不受支持的化学结构,则会报错。这两种格式均可打开或导入到“受管存储库”中。若包含不受支持的化学结构,则会报错;导入存储库时,原始绘图将被保留。
- 反应文档可以导出为
.rxn,.rdf,.rsmi,.rinchi,或带反应的.cml. Save to Managed Repository...创建一个受管存储库条目,而不是通用导出。- 存储库的保存流程故意设计得比“导出”功能更为严格:它仅接受AtomLens能够直接在分子或反应窗口中重新打开的化学文件格式。
© 2026 Dr. Sascha Losko - Obscure Essentials。保留所有权利。