Verwaltetes Repository und iCloud-Synchronisierung
Verwende das verwaltete Repository, wenn du möchtest, dass AtomLens eine kuratierte Bibliothek mit Dateien verwaltet, die es direkt wieder öffnen kann – optional mit einer durch iCloud unterstützten Synchronisierung.
- Der „Managed Repository“-Browser hat ein eigenes Singleton-Fenster und nutzt dieselben Steuerelemente für Suche, Filterung, Sortierung, „Quick Look“, Freigabe und „Finder Reveal“ wie die „Lokalen Molekül-Dateien“ – zusätzlich gibt es die Möglichkeit, Dateien ausschließlich aus dem Repository zu löschen.
- Das Verwaltetes Repository Der Einstellungsbereich enthält
Sync chemical files over iCloud, das festlegt, ob verwaltete Inhalte über iCloud synchronisiert werden oder lokal auf diesem Gerät verbleiben. - Bei iPad ist das verwaltete Repository der primäre Arbeitsbereich, und die entsprechende Symbolleistenaktion kehrt dorthin zurück. Der umfassende Browser für lokale Moleküldateien ist nur bei macOS verfügbar.
Repository-Fenster
„Managed Repository“ ist der Browser für verwaltete Bibliotheken mit Chemiedateien von AtomLens. Er ist bewusst auf lokale Moleküldateien abgestimmt, sodass dort dieselben Funktionen wie Rasteransicht, Sortiersteuerung, Schnellansicht, Freigabe und der „Finder Reveal“-Ablauf ebenfalls funktionieren.
- Nutze lokale Molekül-Dateien für eine umfassende, von Spotlight unterstützte Suche in allen Chemie-Dateien, die sich bereits auf deinem Mac befinden.
- Verwende das verwaltete Repository für AtomLens-verwaltete Einträge, die du als Bibliothek behalten möchtest.
- Auf macOS steht „Managed Repository durchsuchen“ als AtomLens-Aktion im Shortcuts-Editor zur Verfügung. Sie öffnet dieses Fenster und führt die angegebene Textabfrage in der bestehenden Repository-Suche durch; die Spotlight-Dateiindizierung wird weiterhin separat vom Metadaten-Importer verwaltet. Für variable Siri-Suchen erstellst du eine persönliche Verknüpfung, die nach Text fragt, die eingegebene Eingabe an das Textfeld der AtomLens-Aktion übergibt und einen einprägsamen Namen hat, wie zum Beispiel „Suche in AtomLens“. Rufe diese persönliche Verknüpfung über ihren Namen auf; Siri fragt dann nach dem Suchbegriff.
- Karten für verwaltete Repositorys konzentrieren sich auf Bibliotheksmetadaten und Vorschauen. Sie zeigen den Dateisystempfad der verwalteten Kopie nicht an.
- Der Browser aktualisiert sich anhand der Beobachtung des gemeinsamen Repositorys, sodass Änderungen an Inhalten und Metadaten automatisch in den Browser zurückfließen können.
- Informationen zu den Meldungen „Scan“, „Cache“, „Text-Index“, „Molekül-Index“ und „Sync“, die in der unteren Statusleiste angezeigt werden, findest du unter Browser-Statusmeldungen.
- Bei macOS entsprechen die Kontextmenüs der Karten der unteren Aktionsleiste. Repository-Einträge können unten gelöscht werden
Delete...Schaltfläche, über das Kontextmenü einer Karte oder mitBackspacenach der Auswahl. Command-Awählt alle sichtbaren Ergebnisse des Managed Repository auf macOS aus, sodass beim Löschen mehrerer Einträge und beim Teilen dasselbe Auswahlmodell wie bei lokalen Dateien verwendet werden kann.- Bei iPad verfügt jede Repository-Karte über kompakte Symbolschaltflächen für Tags, das Teilen und das Löschen. Wenn du auf die Karte selbst tippst, wird der Eintrag geöffnet.
Chemie-Dokumente mit Shortcuts automatisieren
Füge in der Apple-App „Shortcuts“ eine Aktion hinzu und suche nach „AtomLens“. Bei Mac und iPad mit OS 26 oder höher verwende die Aktionen „Chemie-Dokumente suchen“, „Chemie-Dokument öffnen“, „Eigenschaften des Chemie-Dokuments abrufen“ und „Chemie-Dokument exportieren“. Diese Aktionen funktionieren mit Dokumenten, die im verwalteten Repository gespeichert sind. Die bestehende Aktion „Mac: Verwaltetes Repository durchsuchen“ öffnet weiterhin den Browser.
- Klicke auf „Chemie-Dokumente suchen“. Gib einen Namen oder ein Stichwort ein; wähle optional einen Molekül- oder Reaktionstyp, eine Farbbezeichnung oder Molekulargewichtsgrenzen aus. Die Standardanzahl der Ergebnisse ist 20, maximal sind 500 möglich.
- Bei einem einzelnen Dokument übergib ein Ergebnis an „Get Chemistry Document Properties“, um dessen Eigenschaften zu berechnen, oder an „Open Chemistry Document“, um es in AtomLens anzuzeigen.
- Leite das Dokument an „Chemie-Dokument exportieren“ weiter und wähle „Original“, „SVG“, „PNG“, „PDF“ oder ein kompatibles chemisches Format aus. Füge die Apple-Aktion „Datei speichern“ oder „Quick Look“ hinzu, um die zurückgegebenen Datei zu verwenden.
Bei macOS / iPadOS 27 führen die Prozesse „Chemie-Dokumente exportieren“ und „Eigenschaften von Chemie-Dokumenten abrufen“ eine Auswahl in einem Schritt durch. Beispiel: Suche Dokumente mit einem Farbetikett, übergebe die Ergebnisse an „Chemie-Dokumente exportieren“ (Option „Original“), und leite die zurückgegebenen Dateien anschließend an „Datei speichern“ weiter. Batches unterstützen bis zu 500 ausgewählte Identifikatoren und 32 MiB kombinierte Ausgabe. Doppelte Auswahlen werden nur einmal verarbeitet; Exporte mit demselben Dateinamen erhalten nummerierte Suffixe.
Bei langen Vorgängen unter OS 27 wird der Fortschritt bei der Suche, der Berechnung von Eigenschaften und dem Export angezeigt. Brich den Vorgang über die Schnittstelle des auslösenden Systems ab, wenn eine „Stopp“-Option angeboten wird. Der Abbruch wird zwischen den Verarbeitungsschritten wirksam; eine bereits laufende chemische Berechnung muss möglicherweise erst abgeschlossen werden. Ein abgebrochener oder fehlgeschlagener Stapel liefert keine Teilauswahl an Dateien zurück.
Die Eigenschaftsberechnung und die Formatkonvertierung unterstützen Dokumente mit einer einzigen Struktur bis zu einer Größe von 8 MiB. Verwende „Original“, um eine vollständige Datei mit mehreren Strukturen oder Reaktionen beizubehalten. Wenn das Original größer ist als das Limit für die Stapelausgabe, nutze die Exportaktion für einzelne Dokumente. Inkompatible Molekül- oder Reaktionsformate führen zu einer Fehlermeldung mit Erläuterung.
Dokumentenverweise folgen dem gespeicherten Element, wenn sich dessen Name ändert. Ein Dokument muss auf dem Gerät verfügbar sein, auf dem die Verknüpfung ausgeführt wird; die iCloud-Übertragung kann noch ausstehen. Unter OS 27 liefern gespeicherte Dokumente und sichtbare Bibliothekskarten zudem Dokumentkontext für den Systemindex von Apple. Ungespeicherte Bearbeitungen und nicht zugehörige externe Dateien sind von diesem Kontext der gespeicherten Dokumente ausgeschlossen.
Du kannst eine persönliche Verknüpfung über Siri anhand ihres Namens aufrufen, wobei die für Siri konfigurierte Sprache verwendet wird. AtomLens bietet Aktionsnamen auf Englisch und Deutsch. Diese Aktionen verarbeiten chemische Daten direkt auf dem Gerät und erfordern weder eine PubChem-Anfrage noch das Hochladen von Dokumenten.
Import aus PubChem
Wähle „PubChem“ in der Symbolleiste des verwalteten Repositorys aus. Gib einen Namen, ein Synonym, eine Compound-ID (CID), eine Substanz-ID (SID), eine Formel, „SMILES“, „InChI“ oder „InChIKey“ ein und wähle „Suchen“. Das System erkennt gängige Eingabeformate automatisch; wähle bei mehrdeutigen Eingaben als Typ eine bestimmte Suchoption aus. Zu den weiteren Identifikatoren gehören Registrierungs- und Datenbankkennungen wie CAS-Nummern.
Die Ergebnisse werden als Strukturkarten in einem separaten, verschiebbaren und in der Größe anpassbaren Fenster auf Mac oder in einem Dialogfeld auf iPad angezeigt. Verwende Weitere Ergebnisse laden Um zu einer anderen Seite zu gelangen, wähle dann Importieren auf einer einzelnen Karte. Die ursprüngliche 2D-SDF-Datei und ihre PubChem-Eigenschaften werden gespeichert als PubChem-CID.sdf im aktuellen Repository, mit dem Molekülnamen „PubChem“ als Anzeigenamen, und die Bibliothek wird aktualisiert. Übereinstimmender Suchtext wird in sichtbaren Namen, CIDs und Formeln hervorgehoben. „PubChem“ kann auch mit Synonymen übereinstimmen, die nicht auf der Karte angezeigt werden. Eine Mehrfachauswahl oder ein Massen-Download ist nicht möglich. Eine hinzugefügte Karte bleibt für die aktuelle Suchsitzung markiert.
Bei Suchanfragen wird deine Eingabe an PubChem PUG REST über das Internet. Vorschauen werden lokal gerendert. AtomLens serialisiert Suchvorgänge und Downloads bei weniger als fünf Anfragen pro Sekunde und wartet ab, wenn PubChem ausgelastet ist. Du kannst eine ausstehende Anfrage abbrechen; ein bereits begonnener Schreibvorgang im Repository wird sicher zu Ende geführt. Importierte Dateien nutzen denselben lokalen oder iCloud-Repository-Speicherort wie andere verwaltete Dateien.
Beispielstrukturen und Reaktionen
Das Managed Repository kann mit gebündelten Beispieldaten für eine Ersteinführung, Demos, Schulungen und die Überprüfung von App Store vorbelegt werden. Der Importer fügt 20 „Entity of the Month“-Strukturen vom Typ ChEBI und 20 von Rhea abgeleitete Reaktionen hinzu.
- Auf dem Begrüßungsbildschirm gibt es die Option „Beispielstrukturen und Reaktionen hinzufügen“. Diese Option ist standardmäßig nur dann aktiviert, wenn das Repository leer ist.
- Derselbe Importeur ist später unter „Einstellungen“ > „Verwaltetes Repository“ mit der Option „Beispielstrukturen und Reaktionen hinzufügen“ verfügbar.
- Beispiele werden am selben Speicherort im verwalteten Repository abgelegt wie die vom Benutzer gespeicherten Einträge, und zwar unter Verwendung von „iCloud“, sofern die Repository-Synchronisierung aktiviert und verfügbar ist.
- Bei der Duplikatsprüfung werden die InChI-Keys der Moleküle und die langen RInChI-Keys der Reaktionen verglichen, sodass beim erneuten Ausführen des Importers bereits im Repository vorhandene Beispiele übersprungen werden.
- Öffne nach dem Import „Datei > Verwaltetes Repository…“ und nutze die Suche, die Schnellansicht, den Filter „Nur Reaktionen“ oder das direkte Öffnen der Karten, um dir die Beispiele anzusehen.
Dateien im Repository speichern
Verwendung File > Save to Managed Repository... wenn du möchtest, dass AtomLens eine verwaltete Kopie des aktuellen Chemiekontexts erstellt.
- Der „Repository-Save“-Ablauf akzeptiert nur Chemieformate, die AtomLens direkt in einem Molekül- oder Reaktionsfenster wieder öffnen kann.
- Visuelle Ergebnisse wie zum Beispiel
SVGBleib bei den „Exportieren“ und „Teilen“-Abläufen. Sie werden nicht als Formate zum Speichern im Repository angeboten. - Auf macOS können Repository-Einträge über
Save to Managed Repository...oder aus ausgewählten Lokale Dateien Karten mit In das verwaltete Repository kopieren. - „In verwaltetes Repository verschieben…“ importiert die ausgewählten Einträge unter „Lokale Dateien“ und verschiebt die Originale nach Bestätigung in den Papierkorb.
- Auch synchronisierte Inhalte von anderen Geräten können hier automatisch angezeigt werden.
Synchronisierungsverhalten
Verwende auf Mac und iPad denselben Apple-Account und aktiviere auf jedem Gerät unter „Einstellungen > Verwaltetes Repository“ die Option „Chemiedateien über iCloud synchronisieren“. AtomLens synchronisiert verwaltete Chemieinhalte, Tags, Favoriten und zuletzt verwendete Einträge über deinen privaten iCloud-Speicher, sofern dieser verfügbar ist.
- Eingegangene Änderungen werden automatisch im Repository aktualisiert. Die erste Synchronisierung einer großen Bibliothek kann eine Weile dauern; lass AtomLens geöffnet und überprüfe den Status des Repositorys, während der Vorgang läuft.
- iCloud vorübergehend unterbrochen – „Automatischer Wiederholungsversuch“ bedeutet, dass der Apple-Dienst ausgelastet ist oder Anfragen vorübergehend begrenzt. AtomLens speichert den Inhalt, und Apple plant den Wiederholungsversuch ein. In den Details wird möglicherweise die Zeit angezeigt, nach der Apple einen Wiederholungsversuch angefordert hat; dies ist keine geschätzte Fertigstellungszeit. Warnungen zu Konto, Speicherplatz und Konflikten bleiben davon unberührt.
- Suchindizes, Miniaturansichten, Dateien und die Systemsuche können nach dem Eintreffen der Inhalte nachziehen. Eine Upload-/Download-Anzeige gibt Auskunft über den Fortschritt, ist aber keine Garantie dafür, dass jedes andere Gerät alle Änderungen bereits erhalten hat.
- Dateien, die nur aus beliebigen Ordnern geöffnet werden, und Darstellungen, die an „Share“ übergeben werden, werden nicht automatisch zur Repository-Synchronisierung hinzugefügt. Speichere eine verwaltete Kopie, wenn sie in die gemeinsame Bibliothek gehört.
Synchronisierte Metadaten und Finder-Bezeichnungen
Während AtomLens auf macOS läuft, können verwaltete Repository-Tags auf Finder-Bezeichnungen für materialisierte Dateien abgebildet werden. iPad stellt verwaltete Dateien und Tags über „Dateien“ zur Verfügung.
- Repository-Tags, Favoriten und zuletzt verwendete Einträge werden bei der Synchronisierung berücksichtigt.
- Änderungen an Finder-Bezeichnungen, die im Repository-Browser vorgenommen wurden, bleiben sowohl in AtomLens als auch im Finder sichtbar.
- Änderungen an Tags, die aus der Ferne synchronisiert wurden, können im Finder übernommen werden, solange AtomLens aktiv ist. Dadurch bleibt der Status der Bezeichnungen geräteübergreifend einheitlicher.
Wenn die Synchronisierung deaktiviert ist
Wenn du ausschaltest Sync chemical files over iCloud In den Einstellungen unter „macOS AtomLens“ bleibt das verwaltete Repository verfügbar und speichert Inhalte lokal auf diesem „Mac“.
- „Lokale Dateien“ bietet weiterhin eine umfassende, von Spotlight unterstützte Suche in Dateien außerhalb von AtomLens.
- Das Fenster „Managed Repository“, die Schaltfläche in der Symbolleiste, der Menüpunkt „Datei“ und der Speichervorgang bleiben sichtbar.
- Bei iPad nutzen „Managed Repository“, „Speichern“, Extraktionsergebnisse, Dateien, „Quick Look“ und die Repository-Suche weiterhin das lokale Managed Repository.
- Du kannst die Synchronisierung später in den Einstellungen wieder aktivieren, um verwaltete Inhalte zurück auf iCloud zu verschieben, sobald sie verfügbar sind.
© 2026 Dr. Sascha Losko – Obscure Essentials. Alle Rechte vorbehalten.